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Handle the "Oops! It's not you, it's us" error when running workflow from Salesforce

Updated over 2 months ago

Issue

When a user attempts to run a workflow from Salesforce using a custom button, they are asked to log in to altaFlow. After logging in, they receive the error message: "Oops! It's not you, it's us.Please try again in a few minutes"

Cause

This error occurs because the Login IP Ranges are enabled and restricted on the user's Salesforce Profile.

When Login IP Ranges are configured for a profile, Salesforce restricts access to only the IP addresses listed. If the integration (altaFlow) attempts to connect or authenticate via a server or process whose IP address is not on that list, the connection is blocked, resulting in the error. If Salesforce is running on Hyperforce infrastructure, the entire range of IP addresses for the used instance must be added due to the dynamic nature of cloud environments.

Solution

Salesforce Administrator must add the IP addresses of the Salesforce organization's instance to the user's profile Login IP Ranges.

Follow the steps below to identify the correct IPs and add them to the profile.

  1. Go to Setup > App Manager (or Manage Connected Apps).

  2. Locate the JWT Metadata API Auth Provider (or relevant Connected App).

  3. Click Manage Profiles.

4. Click the Profile Name you wish to edit.

5. Go to Login IP Ranges and click New.

6. Add the required IP ranges and Save.

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